Jump to content
evina

TheEvina's DragHatch

Recommended Posts

For some reason I can get an egg in the ER but not in the main part of the hatchery.

Share this post


Link to post

Awesome. Went straight to the site before checking here and it's working like a charm. Thanks so much for the site. It's a huge help with my babies.

Share this post


Link to post

I really like the layout of this fansite. Nice and simple and it has an er. I will be added this one to the list of fansites I use. I needed an other one. Thank you for all you hard work.

Share this post


Link to post

I like this site! The problem is that there were a lot of adults on there before I just removed them. You should check it more often, if that's your job.

Share this post


Link to post

We likes it. laugh.gif

Share this post


Link to post
I like this site! The problem is that there were a lot of adults on there before I just removed them. You should check it more often, if that's your job.

The system is designed to automatically remove adult, fogged and frozen dragons. But I don't think It's working too well. I'm working on trying to improve it.

Share this post


Link to post

I like the look of this site -- very simple. I just added one of my eggs that needs a little boost. Am anxious to see how well the site works in getting views. If it does well it will definitely become one of my regulars.

Share this post


Link to post

I have a question... I have a hatchling with 3d 21h left, but it says i cant add it to the er. does it have to have less time?

Share this post


Link to post

There seems to be a strange glitch in the API where, very often, once a dragon gets below 5 days remaining, an extra day gets added to the reported time, even though the time on the /view/CODE page is still correct. So even though your hatchling had 3D 21H left, the API would report it as 4D 21H and not an ER. Assuming DragHatch uses the API, I'm guessing that's what happened.

Share this post


Link to post

There seems to be a strange glitch in the API where, very often, once a dragon gets below 5 days remaining, an extra day gets added to the reported time, even though the time on the /view/CODE page is still correct.  So even though your hatchling had 3D 21H left, the API would report it as 4D 21H and not an ER.  Assuming DragHatch uses the API, I'm guessing that's what happened.

Yes I use the API. I'm starting to wonder if it's caused by incubate...

 

EDIT: I added the site to the wiki.

Edited by evina

Share this post


Link to post

I hope you'll add the "Add scroll name" for those that are lazy-like me- option...

 

Of course,I see that it's already in works,wonder how much that'll take though....

Share this post


Link to post

I hope you'll add the "Add scroll name" for those that are lazy-like me- option...

 

Of course,I see that it's already in works,wonder how much that'll take though....

Yeah, the problem is I really don't like the way the API is set up so it might take a while. I've been working on other projects lately because I got temporarily tired of the programming required for DragHatch.

 

EDIT: Version 2.2.0. released.

Edited by evina

Share this post


Link to post

I think I might have just found a bug (or an oversight).

 

I just went to remove a hatchling from your site, which I couldn't remember if I'd already removed it or not, so I wanted to confirm -- and was told "successfully removed." No problem so far, perhaps I just forgot to remove it earlier.

 

Then to make sure it was my forgetfulness, rather than someone "helping", I tried removing a couple eggs which I know I never posted there -- and those came back "successfully removed" too!

 

And then, just out of curiousity, I tried removing those same eggs again. Mere seconds later. And again, "successfully removed." Yet I highly doubt someone re-added my dragons that quickly.

 

So now I'm curious -- how does the remove message actually work? Does it say "removed" any time the code is not in the database, rather than checking if it was, in fact, removed? Or do I really have a problem with someone constantly adding my dragons, such that I actually did remove them each time I tried?

Share this post


Link to post

I think I might have just found a bug (or an oversight).

 

I just went to remove a hatchling from your site, which I couldn't remember if I'd already removed it or not, so I wanted to confirm -- and was told "successfully removed."  No problem so far, perhaps I just forgot to remove it earlier.

 

Then to make sure it was my forgetfulness, rather than someone "helping", I tried removing a couple eggs which I know I never posted there -- and those came back "successfully removed" too!

 

And then, just out of curiousity, I tried removing those same eggs again.  Mere seconds later.  And again, "successfully removed."  Yet I highly doubt someone re-added my dragons that quickly.

 

So now I'm curious -- how does the remove message actually work?  Does it say "removed" any time the code is not in the database, rather than checking if it was, in fact, removed?  Or do I really have a problem with someone constantly adding my dragons, such that I actually did remove them each time I tried?

The server has to do more work to check if an egg/hatchling already exists before it removes it, so I just haven't added that feature. (I might add it in the future.)

 

So the message right now means: whether the dragon was there or not, it isn't there now.

Edited by evina

Share this post


Link to post

Oooh, an automated hatchery, which are my favorites, and I've just found it. Yay. Dragons added and site bookmarked for future use. Thank you.

Share this post


Link to post

Hi there. I'm curious, because I'm having trouble adding 2 hatchies will less than 4 days on them. One is at 3d 7h, the other at 3d 3h. I can't seem to add them to your ER, or the one in Silvi's Lair. Jae's adds just fine, so I'm wondering what's going on?

 

It's not a big deal to me, as they've got enough views to eventually grow up. But I'm wondering if this is a glitch because of some of the new changes? When they were eggs, both were Incubated, so could your system and Silvi's possibly be viewing them as over 4 days?

 

This is something recent, within the last week. I added some dragons before, and had no problems.

 

Just giving a head's up, incase something is off with the coding. happy.gif

Share this post


Link to post

  • Recently Browsing   0 members

    No registered users viewing this page.