Jump to content
Sign in to follow this  
pinkgothic

Minor bug: /dragons page sporadically generating views

Recommended Posts

I dimly recall we're supposed to put bug reports into their own threads here in Help, so I'm going to paste my observations from Tiny Little Questions into this thread to draw some attention to this bug.

 

It's not a huge problem, but it's made fresh eggs of mine sick before whenever I was nervously refreshing when I'd next free up some egg space during a release, and while I now finally know to spot this and work around it, others using the might not realise what's going on, so it might be good to fix:

  

3 hours ago, pinkgothic said:

Has anyone ever noticed a phenomenon whereby refreshing the /dragons page increases the total views counter for some dragons, but not for others? I've noticed several times before that eggs of mine that were only in Valley Sherwood to my knowledge (and which I took out of there, after looking at all other sites I know of to see if they were there) were gaining views exactly with the pace that I refreshed the /dragons page, even if I slowed down or sped up my refreshes considerably - "Views" would always have gone up by exactly +1 when I reloaded (from the previous page load).

 

e.g. right now this was happening for my White/Undine hybrids, and they got sick from this (because I view my /dragons page quite frequently). Nothing to worry about, this is only because they're very young, but it was pretty striking.

 

(Other eggs are also in Valley Sherwood and not showing this behaviour.)

 

It's almost as though the /1.gif suffix of the egg image URL sometimes isn't actually preventing the view as it's meant to. I can't quite figure out what the common cause of this is - in this case the eggs were bred eggs, but it's not happening for bred hatchlings on my scroll, so that won't be it, and indeed it tends to just happen for a certain amount of time and then stop.

 

Anyone ever observed this?

 

  

25 minutes ago, pinkgothic said:
Quote

If they've hit their total views allowed they won't increase. 1 unique view allows for 15 total views (2 = 30, and so on...). Could that be it, or have I misread the question?

 

Misread the question, unfortunately, sorry for being unclear.

 

When I visit the /dragons page (the logged in version of my scroll, not the public scroll), usually the views of the eggs will not increase, regardless how often I open the page. I would need to go to the public scroll link. The reason is that the images embedded on /dragons have URLs like https://dragcave.net/image/i9UlX/1.gif instead of https://dragcave.net/image/i9UlX.gif - the extra /1 in the URL tells dragcave.net not to count a view for that dragon.

 

But I've noticed that sometimes, dragons seem to count up views from the /dragons page despite that - but it only happens for some of the dragons.

 

This is completely independent of the 15-views-per-1-unique-view cap. e.g. there is an egg on my scroll that currently has the stats 125 V, 54 UV, 2 C. I can refresh /dragons as much as I want and the 125 UV does not go up. But earlier, it was doing exactly that.

 

This behaviour has happened to me several times before, but I've been dismissing it as "it has to be in a hatchery somewhere that you just don't know about", despite the suspiciously precise correlation with my /dragons page reloads. This is the first time I'm absolutely certain my own refreshes were doing it, because I deliberately varied the speed at which I reloaded quite strongly (both slowing it down and speeding it up), and the increase kept pace with my reload count exactly.

 

So my guess is that in some cases, the /1 addition in the URL is not actually preventing the view from counting. I don't know what "in some cases" is. Maybe it's "whenever the egg has only 1 click". Maybe it's "any bred egg in the first five hours of its life". Maybe it only happens to certain species (the last time I know it definitely happened was with a forest zyumorph - I was really confused about that one).

 

I don't have enough data yet to guess at what is causing it, but at this point I'm no longer willing to assume it's just in my head.

 

Edit: Just to be clear, I've only very rarely observed this. This is in part going to be because it takes certain events and circumstances for me to be refreshing that page a lot, but I assume it's also rare in general. In this case it was just two eggs out of 21 growing things doing it.

 

 

Herk also mentioned having noticed this previously, and I have a casual report from a newer player who thought this was just how Dragon Cave worked in general (as in, he thought it always happened that way, but hadn't investigated).

 

I don't have any plug-ins that would affect this (at least I doubt Mailvelope, the Google Play last.fm Scrobbler, or Google Authenticator would cause this). The /1 was also definitely still in the image URLs of the affected eggs earlier when it was happening to them (checked using DOM inspection).

 

Thanks for reading!

Edited by pinkgothic

Share this post


Link to post

Heads-up, this is currently happening to this egg: https://dragcave.net/lineage/geKTU

 

I've warded it.

 

Edit: It stopped after I went to its /view/ page. Don't know if that's just a coincidence, but figured I'd mention it. Will continue keeping an eye on this (rare) phenomenon.

Edited by pinkgothic

Share this post


Link to post
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.