Jump to content
Sign in to follow this  
Laryal

hatchlings dead why

Recommended Posts

Posted (edited)

Hello ok i had two of the new Valentines day eggs had them all set up an on the third day put them in fan sight.I knew i was going to be very busy cam on today an they are dead. how can i get them back i felt bad after seeing the graves. :(

 

https://dragcave.net/view/vJxOE

 

https://dragcave.net/view/ShIGr

Edited by Laryal

Share this post


Link to post

Posted (edited)

It looks like they didn't get enough views to grow. Eggs often require more care and attention than putting them in one fansite and forgetting about them, especially during holidays when the hatcheries are so full that a given egg will be rotated in less often. All I can suggest is to grab them next year.

Edited by Keileon

Share this post


Link to post

thanks i put them in as many as i could i was was so busy i could not come back till now. :(

 

Share this post


Link to post

Posted (edited)

You can try the revive feature in actions.  Though you only get one chance to revive.  They didn't get enough views to grow up is what happened sadly.  You do have a chance to replace them next year at valentine breeding season in the holiday biome that has the previous years cb eggs in it.  Sorry for your loss.

 

Edit:  For more fan site options check out this forum https://forums.dragcave.net/forum/20-fan-sites/

Edited by Dracaena

Share this post


Link to post

Thanks i  did just try to revive them but no good an i will try next year thanks you both. :)

 

Share this post


Link to post

Posted (edited)

Wow, did you fog them after they hatched? These stats are so low I'm surprised they managed to hatch after three days, I've had ND experiments which barely hatched with slightly higher UVs than that. So, the stats can't have risen much after hatching...

Edited by olympe

Share this post


Link to post
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.